添加到收藏    打印

Perl云主机版本说明

Perl云主机基本版本和框架配置如下:

Perl 5.8 5.10 5.12 5.14 5.16 5.18
Catalyst 5.9 5.9 5.9 5.9 5.9 5.9
CGI::Application 4.5 4.5 4.5 4.5 4.5 4.5
Dancer 1.3 1.3 1.3 1.3 1.3 1.3
Embperl 2.5 2.5 2.5 2.5 2.5 2.5
Jifty 1.1 1.1 1.1 1.1 1.1 1.1
Mojolicious 不支持 4.93 4.93 4.93 4.93 4.93

选择Perl版本的方法

通过env:

#!/bin/env perl5.8
#!/bin/env perl5.10
#!/bin/env perl5.12
#!/bin/env perl5.14
#!/bin/env perl5.16
#!/bin/env perl5.18

通过指定运行文件

#!/usr/bin/perl5.8
#!/usr/bin/perl5.10
#!/usr/bin/perl5.12
#!/usr/bin/perl5.14
#!/usr/bin/perl5.16
#!/usr/bin/perl5.18

或者

#!/usr/local/perl58/bin/perl
#!/usr/local/perl510/bin/perl
#!/usr/local/perl512/bin/perl
#!/usr/local/perl514/bin/perl
#!/usr/local/perl516/bin/perl
#!/usr/local/perl518/bin/perl

为了满足您的特定需求,捌号主机上可以完全自定义自己的Perl环境,详情参见:自定义Perl运行环境



此答案有用么?

建议阅读